Schwachstellen / CVE-2022-39379

kritisch

CVE-2022-39379

fluentd: remote code execution via crafted JSON payloads

Veröffentlicht Geändert CWE 502
In der Trivy Database seit spätestens 24. Okt. 2026, 07:11 UTCWann der Eintrag vor diesem Build hinzukam, ist nicht erfasst.

Einstufung nach Quelle

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GHSA3.1CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Red Hat8.1CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Bitnami9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Trivys eigenes Label ist CRITICAL. Kritisch laut NVD, Bitnami, Photon OS. Niedriger laut Red Hat (mittel), GHSA (niedrig), CBL-Mariner (niedrig), Ruby Advisory DB (niedrig).

Beschreibung

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.

Betroffene Pakete und behobene Versionen

QuellePaketBehoben in
bitnami::Bitnami Vulnerability Databasefluentd1.15.3
Photon OS 4.0rubygem-fluentd1.15.3-1.ph4
Photon OS 5.0rubygem-fluentd1.15.2-4.ph5
CBL-Mariner 2.0rubygem-fluentd0:1.14.6-2.cm2
Red Hatfluentd, fluentd-doc, puppet-fluentdkein Fix angegeben
rubygems::GitHub Security Advisory RubyGemsfluentd1.15.3
rubygems::Ruby Advisory Databasefluentd>= 1.15.3
Alle 9 Einträge aus 7 Quellen zeigen
QuellePaketBehoben in
bitnami::Bitnami Vulnerability Databasefluentd1.15.3
Photon OS 4.0rubygem-fluentd1.15.3-1.ph4
Photon OS 5.0rubygem-fluentd1.15.2-4.ph5
CBL-Mariner 2.0rubygem-fluentd0:1.14.6-2.cm2
Red Hatfluentdkein Fix angegeben
Red Hatfluentd-dockein Fix angegeben
Red Hatpuppet-fluentdkein Fix angegeben
rubygems::GitHub Security Advisory RubyGemsfluentd1.15.3
rubygems::Ruby Advisory Databasefluentd>= 1.15.3

Referenzen

Alle 10 Referenzen

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.