CVE-2022-39379
fluentd: remote code execution via crafted JSON payloads
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según NVD, Bitnami, Photon OS. Más baja según Red Hat (media), GHSA (baja), CBL-Mariner (baja), Ruby Advisory DB (baja).
Descripción
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | fluentd | 1.15.3 |
| Photon OS 4.0 | rubygem-fluentd | 1.15.3-1.ph4 |
| Photon OS 5.0 | rubygem-fluentd | 1.15.2-4.ph5 |
| CBL-Mariner 2.0 | rubygem-fluentd | 0:1.14.6-2.cm2 |
| Red Hat | fluentd, fluentd-doc, puppet-fluentd | sin corrección indicada |
| rubygems::GitHub Security Advisory RubyGems | fluentd | 1.15.3 |
| rubygems::Ruby Advisory Database | fluentd | >= 1.15.3 |
Mostrar las 9 entradas de 7 fuentes
| Fuente | Paquete | Corregido en |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | fluentd | 1.15.3 |
| Photon OS 4.0 | rubygem-fluentd | 1.15.3-1.ph4 |
| Photon OS 5.0 | rubygem-fluentd | 1.15.2-4.ph5 |
| CBL-Mariner 2.0 | rubygem-fluentd | 0:1.14.6-2.cm2 |
| Red Hat | fluentd | sin corrección indicada |
| Red Hat | fluentd-doc | sin corrección indicada |
| Red Hat | puppet-fluentd | sin corrección indicada |
| rubygems::GitHub Security Advisory RubyGems | fluentd | 1.15.3 |
| rubygems::Ruby Advisory Database | fluentd | >= 1.15.3 |
Referencias
- https://access.redhat.com/security/cve/CVE-2022-39379
- https://github.com/fluent/fluentd
- https://github.com/fluent/fluentd/commit/48e5b85dab1b6d4c273090d538fc11b3f2fd8135
- https://github.com/fluent/fluentd/security/advisories/GHSA-fppq-mj76-fpj2
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/fluentd/CVE-2022-39379.yml
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MYD5QV66OLDHES6IKVYYM3Y3YID3VVCO
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MYD5QV66OLDHES6IKVYYM3Y3YID3VVCO/
- https://nvd.nist.gov/vuln/detail/CVE-2022-39379