CVE-2022-39379
fluentd: remote code execution via crafted JSON payloads
Kaynağa göre önem derecesi
Trivy'nin kendi etiketi CRITICAL. Kritik diyenler: NVD, Bitnami, Photon OS. Daha düşük diyenler: Red Hat (orta), GHSA (düşük), CBL-Mariner (düşük), Ruby Advisory DB (düşük).
Açıklama
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.
Etkilenen paketler ve düzeltilmiş sürümler
| Kaynak | Paket | Düzeltildiği sürüm |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | fluentd | 1.15.3 |
| Photon OS 4.0 | rubygem-fluentd | 1.15.3-1.ph4 |
| Photon OS 5.0 | rubygem-fluentd | 1.15.2-4.ph5 |
| CBL-Mariner 2.0 | rubygem-fluentd | 0:1.14.6-2.cm2 |
| Red Hat | fluentd, fluentd-doc, puppet-fluentd | düzeltme belirtilmemiş |
| rubygems::GitHub Security Advisory RubyGems | fluentd | 1.15.3 |
| rubygems::Ruby Advisory Database | fluentd | >= 1.15.3 |
7 kaynaktaki 9 kaydın hepsini göster
| Kaynak | Paket | Düzeltildiği sürüm |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | fluentd | 1.15.3 |
| Photon OS 4.0 | rubygem-fluentd | 1.15.3-1.ph4 |
| Photon OS 5.0 | rubygem-fluentd | 1.15.2-4.ph5 |
| CBL-Mariner 2.0 | rubygem-fluentd | 0:1.14.6-2.cm2 |
| Red Hat | fluentd | düzeltme belirtilmemiş |
| Red Hat | fluentd-doc | düzeltme belirtilmemiş |
| Red Hat | puppet-fluentd | düzeltme belirtilmemiş |
| rubygems::GitHub Security Advisory RubyGems | fluentd | 1.15.3 |
| rubygems::Ruby Advisory Database | fluentd | >= 1.15.3 |
Referanslar
- https://access.redhat.com/security/cve/CVE-2022-39379
- https://github.com/fluent/fluentd
- https://github.com/fluent/fluentd/commit/48e5b85dab1b6d4c273090d538fc11b3f2fd8135
- https://github.com/fluent/fluentd/security/advisories/GHSA-fppq-mj76-fpj2
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/fluentd/CVE-2022-39379.yml
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MYD5QV66OLDHES6IKVYYM3Y3YID3VVCO
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MYD5QV66OLDHES6IKVYYM3Y3YID3VVCO/
- https://nvd.nist.gov/vuln/detail/CVE-2022-39379