CVE-2023-38495
Possible image tampering from missing image validation for Packages
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, Bitnami. Rated lower by GHSA (high).
Description
Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, Crossplane's image backend does not validate the byte contents of Crossplane packages. As such, Crossplane does not detect if an attacker has tampered with a Package. The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0. As a workaround, only use images from trusted sources and keep Package editing/creating privileges to administrators only.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | crossplane | 1.11.5, 1.12.3 |
| chainguard | crossplane | 0 |
| go::GitHub Security Advisory Go | github.com/crossplane/crossplane | 1.11.5, 1.12.3 |
| wolfi | crossplane | 0 |