CVE-2023-38495
Possible image tampering from missing image validation for Packages
Kaynağa göre önem derecesi
Trivy'nin kendi etiketi CRITICAL. Kritik diyenler: NVD, Bitnami. Daha düşük diyenler: GHSA (yüksek).
Açıklama
Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, Crossplane's image backend does not validate the byte contents of Crossplane packages. As such, Crossplane does not detect if an attacker has tampered with a Package. The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0. As a workaround, only use images from trusted sources and keep Package editing/creating privileges to administrators only.
Etkilenen paketler ve düzeltilmiş sürümler
| Kaynak | Paket | Düzeltildiği sürüm |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | crossplane | 1.11.5, 1.12.3 |
| chainguard | crossplane | 0 |
| go::GitHub Security Advisory Go | github.com/crossplane/crossplane | 1.11.5, 1.12.3 |
| wolfi | crossplane | 0 |