CVE-2019-5421
Plataformatec Devise version 4.5.0 and earlier, using the lockable mod ...
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, Ruby Advisory DB. Rated lower by GHSA (medium), Ubuntu (low).
Description
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| rubygems::Ruby Advisory Database | devise | >= 4.6.0 |
| debian 11 | ruby-devise | 4.5.0-3 |
| debian 12 | ruby-devise | 4.5.0-3 |
| debian 9 | ruby-devise | no fix listed |
| echo | ruby-devise | 4.5.0-3 |
| rubygems::GitHub Security Advisory RubyGems | devise | 4.6.0 |
| ubuntu 18.04-ESM | ruby-devise | no fix listed |
| ubuntu 19.10 | ruby-devise | 4.5.0-3 |
| ubuntu 20.04 | ruby-devise | 4.5.0-3 |
| ubuntu 20.04-ESM | ruby-devise | 4.5.0-3 |
| ubuntu 20.10 | ruby-devise | 4.5.0-3 |
| ubuntu 21.04 | ruby-devise | 4.5.0-3 |
Show all 20 entries from 20 sources
| Source | Package | Fixed in |
|---|---|---|
| rubygems::Ruby Advisory Database | devise | >= 4.6.0 |
| debian 11 | ruby-devise | 4.5.0-3 |
| debian 12 | ruby-devise | 4.5.0-3 |
| debian 9 | ruby-devise | no fix listed |
| echo | ruby-devise | 4.5.0-3 |
| rubygems::GitHub Security Advisory RubyGems | devise | 4.6.0 |
| ubuntu 18.04-ESM | ruby-devise | no fix listed |
| ubuntu 19.10 | ruby-devise | 4.5.0-3 |
| ubuntu 20.04 | ruby-devise | 4.5.0-3 |
| ubuntu 20.04-ESM | ruby-devise | 4.5.0-3 |
| ubuntu 20.10 | ruby-devise | 4.5.0-3 |
| ubuntu 21.04 | ruby-devise | 4.5.0-3 |
| ubuntu 21.10 | ruby-devise | 4.5.0-3 |
| ubuntu 22.04 | ruby-devise | 4.5.0-3 |
| ubuntu 22.10 | ruby-devise | 4.5.0-3 |
| ubuntu 23.04 | ruby-devise | 4.5.0-3 |
| ubuntu 23.10 | ruby-devise | 4.5.0-3 |
| ubuntu 24.04 | ruby-devise | 4.5.0-3 |
| ubuntu 24.10 | ruby-devise | 4.5.0-3 |
| ubuntu 25.04 | ruby-devise | 4.5.0-3 |