Vulnérabilités / CVE-2019-5421

critique

CVE-2019-5421

Plataformatec Devise version 4.5.0 and earlier, using the lockable mod ...

Publiée Modifiée CWE 367, 307
Dans la Trivy database depuis au moins le 24 oct. 2026, 07:11 UTCLa date d'entrée avant ce build n'est pas enregistrée.

Sévérité par source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Le label propre à Trivy est CRITICAL. Critique selon NVD, Ruby Advisory DB. Plus basse selon GHSA (moyenne), Ubuntu (faible).

Description

Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.

Paquets affectés et versions corrigées

SourcePaquetCorrigé en
rubygems::Ruby Advisory Databasedevise>= 4.6.0
debian 11ruby-devise4.5.0-3
debian 12ruby-devise4.5.0-3
debian 9ruby-devisepas de correctif indiqué
echoruby-devise4.5.0-3
rubygems::GitHub Security Advisory RubyGemsdevise4.6.0
ubuntu 18.04-ESMruby-devisepas de correctif indiqué
ubuntu 19.10ruby-devise4.5.0-3
ubuntu 20.04ruby-devise4.5.0-3
ubuntu 20.04-ESMruby-devise4.5.0-3
ubuntu 20.10ruby-devise4.5.0-3
ubuntu 21.04ruby-devise4.5.0-3
Afficher les 20 entrées de 20 sources
SourcePaquetCorrigé en
rubygems::Ruby Advisory Databasedevise>= 4.6.0
debian 11ruby-devise4.5.0-3
debian 12ruby-devise4.5.0-3
debian 9ruby-devisepas de correctif indiqué
echoruby-devise4.5.0-3
rubygems::GitHub Security Advisory RubyGemsdevise4.6.0
ubuntu 18.04-ESMruby-devisepas de correctif indiqué
ubuntu 19.10ruby-devise4.5.0-3
ubuntu 20.04ruby-devise4.5.0-3
ubuntu 20.04-ESMruby-devise4.5.0-3
ubuntu 20.10ruby-devise4.5.0-3
ubuntu 21.04ruby-devise4.5.0-3
ubuntu 21.10ruby-devise4.5.0-3
ubuntu 22.04ruby-devise4.5.0-3
ubuntu 22.10ruby-devise4.5.0-3
ubuntu 23.04ruby-devise4.5.0-3
ubuntu 23.10ruby-devise4.5.0-3
ubuntu 24.04ruby-devise4.5.0-3
ubuntu 24.10ruby-devise4.5.0-3
ubuntu 25.04ruby-devise4.5.0-3

Références

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.