Schwachstellen / CVE-2025-54988

kritisch

CVE-2025-54988

org.apache.tika/tika-parser-pdf-module: Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA

Veröffentlicht Geändert CWE 611
In der Trivy Database seit spätestens 24. Okt. 2026, 07:11 UTCWann der Eintrag vor diesem Build hinzukam, ist nicht erfasst.

Einstufung nach Quelle

GHSA9.3CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Red Hat9.4CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L

Trivys eigenes Label ist CRITICAL. Kritisch laut GHSA, Red Hat. Niedriger laut Ubuntu (mittel).

Beschreibung

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.

Betroffene Pakete und behobene Versionen

QuellePaketBehoben in
maven::GitHub Security Advisory Mavenorg.apache.tika:tika-parser-pdf-module, org.apache.tika:tika-parsers3.2.2 und 1 weitere
chainguardelasticsearch-8.17, elasticsearch-fips-9.0, elasticsearch-fips-9.1 und 4 weitere8.17.10-r1 und 5 weitere
debian 11tika1.22-2+deb11u1
minimosapache-tika-3.0, apache-tika-3.1, elasticsearch-8 und 3 weitere3.0.0-r5 und 5 weitere
ubuntu 18.04-ESMtikakein Fix angegeben
ubuntu 20.04-ESMtika1.22-1ubuntu0.1~esm2
ubuntu 22.04tika1.22-2+deb11u1build0.22.04.1
ubuntu 24.04tikakein Fix angegeben
ubuntu 26.04tikakein Fix angegeben
ubuntu 26.10tikakein Fix angegeben
wolfiopensearch-2, opensearch-32.19.4-r0 und 1 weitere
Alle 24 Einträge aus 11 Quellen zeigen
QuellePaketBehoben in
maven::GitHub Security Advisory Mavenorg.apache.tika:tika-parser-pdf-module3.2.2
maven::GitHub Security Advisory Mavenorg.apache.tika:tika-parsers2.0.0-ALPHA
chainguardelasticsearch-8.178.17.10-r1
chainguardelasticsearch-fips-9.09.0.8-r0
chainguardelasticsearch-fips-9.19.1.2-r12
chainguardopensearch-22.19.4-r0
chainguardopensearch-33.3.2-r0
chainguardsolr-90
chainguardsolr-fips-90
debian 11tika1.22-2+deb11u1
minimosapache-tika-3.03.0.0-r5
minimosapache-tika-3.13.1.0-r5
minimoselasticsearch-88.19.3-r0
minimoselasticsearch-9.19.1.4-r0
minimosopensearch-22.19.4-r0
minimosopensearch-33.3.0-r0
ubuntu 18.04-ESMtikakein Fix angegeben
ubuntu 20.04-ESMtika1.22-1ubuntu0.1~esm2
ubuntu 22.04tika1.22-2+deb11u1build0.22.04.1
ubuntu 24.04tikakein Fix angegeben
ubuntu 26.04tikakein Fix angegeben
ubuntu 26.10tikakein Fix angegeben
wolfiopensearch-22.19.4-r0
wolfiopensearch-33.3.2-r0

Referenzen

Alle 16 Referenzen

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.