Vulnerabilidades / CVE-2025-54988

crítica

CVE-2025-54988

org.apache.tika/tika-parser-pdf-module: Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA

Publicada Modificada CWE 611
En la Trivy database desde, como mínimo, el 24 oct 2026, 07:11 UTCNo consta cuándo entró antes de ese build.

Severidad por fuente

GHSA9.3CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Red Hat9.4CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L

La etiqueta propia de Trivy es CRITICAL. Crítica según GHSA, Red Hat. Más baja según Ubuntu (media).

Descripción

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.

Paquetes afectados y versiones corregidas

FuentePaqueteCorregido en
maven::GitHub Security Advisory Mavenorg.apache.tika:tika-parser-pdf-module, org.apache.tika:tika-parsers3.2.2 y 1 más
chainguardelasticsearch-8.17, elasticsearch-fips-9.0, elasticsearch-fips-9.1 y 4 más8.17.10-r1 y 5 más
debian 11tika1.22-2+deb11u1
minimosapache-tika-3.0, apache-tika-3.1, elasticsearch-8 y 3 más3.0.0-r5 y 5 más
ubuntu 18.04-ESMtikasin corrección indicada
ubuntu 20.04-ESMtika1.22-1ubuntu0.1~esm2
ubuntu 22.04tika1.22-2+deb11u1build0.22.04.1
ubuntu 24.04tikasin corrección indicada
ubuntu 26.04tikasin corrección indicada
ubuntu 26.10tikasin corrección indicada
wolfiopensearch-2, opensearch-32.19.4-r0 y 1 más
Mostrar las 24 entradas de 11 fuentes
FuentePaqueteCorregido en
maven::GitHub Security Advisory Mavenorg.apache.tika:tika-parser-pdf-module3.2.2
maven::GitHub Security Advisory Mavenorg.apache.tika:tika-parsers2.0.0-ALPHA
chainguardelasticsearch-8.178.17.10-r1
chainguardelasticsearch-fips-9.09.0.8-r0
chainguardelasticsearch-fips-9.19.1.2-r12
chainguardopensearch-22.19.4-r0
chainguardopensearch-33.3.2-r0
chainguardsolr-90
chainguardsolr-fips-90
debian 11tika1.22-2+deb11u1
minimosapache-tika-3.03.0.0-r5
minimosapache-tika-3.13.1.0-r5
minimoselasticsearch-88.19.3-r0
minimoselasticsearch-9.19.1.4-r0
minimosopensearch-22.19.4-r0
minimosopensearch-33.3.0-r0
ubuntu 18.04-ESMtikasin corrección indicada
ubuntu 20.04-ESMtika1.22-1ubuntu0.1~esm2
ubuntu 22.04tika1.22-2+deb11u1build0.22.04.1
ubuntu 24.04tikasin corrección indicada
ubuntu 26.04tikasin corrección indicada
ubuntu 26.10tikasin corrección indicada
wolfiopensearch-22.19.4-r0
wolfiopensearch-33.3.2-r0

Referencias

Las 16 referencias

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.