Schwachstellen / CVE-2024-45409

kritisch

CVE-2024-45409

The Ruby SAML library is for implementing the client side of a SAML au ...

Veröffentlicht Geändert CWE 347
In der Trivy Database seit spätestens 24. Okt. 2026, 07:11 UTCWann der Eintrag vor diesem Build hinzukam, ist nicht erfasst.

Einstufung nach Quelle

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GHSA9.9CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
Bitnami9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Trivys eigenes Label ist CRITICAL. Kritisch laut NVD, GHSA, Bitnami, Ruby Advisory DB. Niedriger laut Ubuntu (mittel).

Beschreibung

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

Betroffene Pakete und behobene Versionen

QuellePaketBehoben in
bitnami::Bitnami Vulnerability Databasegitlab16.11.10, 17.0.8, 17.1.8, 17.2.7, 17.3.3
rubygems::GitHub Security Advisory RubyGemsruby-saml1.12.3, 1.17.0
rubygems::Ruby Advisory Databaseomniauth-saml, ruby-saml>= 1.10.5, < 2.0.0, ~> 2.1.2, >= 2.2.1 und 1 weitere
debian 11ruby-saml1.11.0-1+deb11u1
debian 12ruby-saml1.13.0-1+deb12u1
echoruby-saml1.13.0-1+deb12u1
rapidfort ubuntu 20.04ruby-saml0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1
rapidfort ubuntu 22.04ruby-saml0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1
rapidfort ubuntu 24.04ruby-saml0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1
ubuntu 16.04-ESMruby-saml1.1.2-1ubuntu1+esm1
ubuntu 18.04-ESMruby-saml1.7.2-1ubuntu0.1~esm1
ubuntu 20.04ruby-saml1.11.0-1ubuntu0.1
Alle 17 Einträge aus 16 Quellen zeigen
QuellePaketBehoben in
bitnami::Bitnami Vulnerability Databasegitlab16.11.10, 17.0.8, 17.1.8, 17.2.7, 17.3.3
rubygems::GitHub Security Advisory RubyGemsruby-saml1.12.3, 1.17.0
rubygems::Ruby Advisory Databaseomniauth-saml>= 1.10.5, < 2.0.0, ~> 2.1.2, >= 2.2.1
rubygems::Ruby Advisory Databaseruby-saml~> 1.12.3, >= 1.17.0
debian 11ruby-saml1.11.0-1+deb11u1
debian 12ruby-saml1.13.0-1+deb12u1
echoruby-saml1.13.0-1+deb12u1
rapidfort ubuntu 20.04ruby-saml0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1
rapidfort ubuntu 22.04ruby-saml0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1
rapidfort ubuntu 24.04ruby-saml0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1
ubuntu 16.04-ESMruby-saml1.1.2-1ubuntu1+esm1
ubuntu 18.04-ESMruby-saml1.7.2-1ubuntu0.1~esm1
ubuntu 20.04ruby-saml1.11.0-1ubuntu0.1
ubuntu 20.04-ESMruby-saml1.11.0-1ubuntu0.1
ubuntu 22.04ruby-saml1.13.0-1ubuntu0.1
ubuntu 24.04ruby-saml1.15.0-1ubuntu0.24.04.1
ubuntu 24.10ruby-saml1.15.0-1ubuntu0.24.10.1

Referenzen

Alle 16 Referenzen

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.