CVE-2024-45409
The Ruby SAML library is for implementing the client side of a SAML au ...
Sévérité par source
Le label propre à Trivy est CRITICAL. Critique selon NVD, GHSA, Bitnami, Ruby Advisory DB. Plus basse selon Ubuntu (moyenne).
Description
The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
Paquets affectés et versions corrigées
| Source | Paquet | Corrigé en |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | gitlab | 16.11.10, 17.0.8, 17.1.8, 17.2.7, 17.3.3 |
| rubygems::GitHub Security Advisory RubyGems | ruby-saml | 1.12.3, 1.17.0 |
| rubygems::Ruby Advisory Database | omniauth-saml, ruby-saml | >= 1.10.5, < 2.0.0, ~> 2.1.2, >= 2.2.1 et 1 autres |
| debian 11 | ruby-saml | 1.11.0-1+deb11u1 |
| debian 12 | ruby-saml | 1.13.0-1+deb12u1 |
| echo | ruby-saml | 1.13.0-1+deb12u1 |
| rapidfort ubuntu 20.04 | ruby-saml | 0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1 |
| rapidfort ubuntu 22.04 | ruby-saml | 0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1 |
| rapidfort ubuntu 24.04 | ruby-saml | 0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1 |
| ubuntu 16.04-ESM | ruby-saml | 1.1.2-1ubuntu1+esm1 |
| ubuntu 18.04-ESM | ruby-saml | 1.7.2-1ubuntu0.1~esm1 |
| ubuntu 20.04 | ruby-saml | 1.11.0-1ubuntu0.1 |
Afficher les 17 entrées de 16 sources
| Source | Paquet | Corrigé en |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | gitlab | 16.11.10, 17.0.8, 17.1.8, 17.2.7, 17.3.3 |
| rubygems::GitHub Security Advisory RubyGems | ruby-saml | 1.12.3, 1.17.0 |
| rubygems::Ruby Advisory Database | omniauth-saml | >= 1.10.5, < 2.0.0, ~> 2.1.2, >= 2.2.1 |
| rubygems::Ruby Advisory Database | ruby-saml | ~> 1.12.3, >= 1.17.0 |
| debian 11 | ruby-saml | 1.11.0-1+deb11u1 |
| debian 12 | ruby-saml | 1.13.0-1+deb12u1 |
| echo | ruby-saml | 1.13.0-1+deb12u1 |
| rapidfort ubuntu 20.04 | ruby-saml | 0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1 |
| rapidfort ubuntu 22.04 | ruby-saml | 0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1 |
| rapidfort ubuntu 24.04 | ruby-saml | 0:1.13.0-1ubuntu0.1, 0:1.15.0-1ubuntu0.24.04.1 |
| ubuntu 16.04-ESM | ruby-saml | 1.1.2-1ubuntu1+esm1 |
| ubuntu 18.04-ESM | ruby-saml | 1.7.2-1ubuntu0.1~esm1 |
| ubuntu 20.04 | ruby-saml | 1.11.0-1ubuntu0.1 |
| ubuntu 20.04-ESM | ruby-saml | 1.11.0-1ubuntu0.1 |
| ubuntu 22.04 | ruby-saml | 1.13.0-1ubuntu0.1 |
| ubuntu 24.04 | ruby-saml | 1.15.0-1ubuntu0.24.04.1 |
| ubuntu 24.10 | ruby-saml | 1.15.0-1ubuntu0.24.10.1 |
Références
- https://github.com/SAML-Toolkits/ruby-saml
- https://github.com/SAML-Toolkits/ruby-saml/commit/1ec5392bc506fe43a02dbb66b68741051c5ffeae
- https://github.com/SAML-Toolkits/ruby-saml/commit/4865d030cae9705ee5cdb12415c654c634093ae7
- https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2
- https://github.com/omniauth/omniauth-saml/commit/4274e9d57e65f2dcaae4aa3b2accf831494f2ddd
- https://github.com/omniauth/omniauth-saml/security/advisories/GHSA-cvp8-5r8g-fhvq
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/CVE-2024-45409.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/GHSA-cvp8-5r8g-fhvq.yml
Les 16 références
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2024-45409.yml
- https://lists.debian.org/debian-lts-announce/2024/11/msg00006.html
- https://news.ycombinator.com/item?id=41586031
- https://nvd.nist.gov/vuln/detail/CVE-2024-45409
- https://security.netapp.com/advisory/ntap-20240926-0008/
- https://ssoready.com/blog/engineering/ruby-saml-pwned-by-xml-signature-wrapping-attacks/
- https://ubuntu.com/security/notices/USN-7309-1
- https://www.cve.org/CVERecord?id=CVE-2024-45409