Schwachstellen / CVE-2020-5214

kritisch

CVE-2020-5214

In NetHack before 3.6.5, detecting an unknown configuration file optio ...

Veröffentlicht Geändert CWE 120
In der Trivy Database seit spätestens 24. Okt. 2026, 07:11 UTCWann der Eintrag vor diesem Build hinzukam, ist nicht erfasst.

Einstufung nach Quelle

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Trivys eigenes Label ist CRITICAL. Kritisch laut NVD. Niedriger laut Ubuntu (niedrig).

Beschreibung

In NetHack before 3.6.5, detecting an unknown configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.

Betroffene Pakete und behobene Versionen

QuellePaketBehoben in
debian 11nethack3.6.6-1
debian 12nethack3.6.6-1
debian 13nethack3.6.6-1
debian 14nethack3.6.6-1
echonethack3.6.6-1
ubuntu 18.04-ESMnethackkein Fix angegeben
ubuntu 20.04-ESMnethackkein Fix angegeben

Referenzen

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.