CVE-2020-5214
In NetHack before 3.6.5, detecting an unknown configuration file optio ...
Kaynağa göre önem derecesi
Trivy'nin kendi etiketi CRITICAL. Kritik diyenler: NVD. Daha düşük diyenler: Ubuntu (düşük).
Açıklama
In NetHack before 3.6.5, detecting an unknown configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.
Etkilenen paketler ve düzeltilmiş sürümler
| Kaynak | Paket | Düzeltildiği sürüm |
|---|---|---|
| debian 11 | nethack | 3.6.6-1 |
| debian 12 | nethack | 3.6.6-1 |
| debian 13 | nethack | 3.6.6-1 |
| debian 14 | nethack | 3.6.6-1 |
| echo | nethack | 3.6.6-1 |
| ubuntu 18.04-ESM | nethack | düzeltme belirtilmemiş |
| ubuntu 20.04-ESM | nethack | düzeltme belirtilmemiş |