Vulnerabilities / GHSA-mf4f-j588-5xm8

critical

GHSA-mf4f-j588-5xm8

Apache Log4j Remote Code Execution

Published Modified
In the Trivy database since at least 24 Oct 2026, 07:11 UTCWhen it arrived before that build is not recorded.

Severity by source

No source gives a CVSS score.

Trivy's own label is CRITICAL. Rated critical by GHSA.

Description

### Impact Opencast uses an Apache Log4j2 version which, combined with older JDK versions, can be used for remote code execution attacks which have been found to be actively exploited. Apache Log4j2 <=2.14.1 JNDI features is not sufficiently protected. An attacker who can control log messages or log message parameters can execute arbitrary code when message lookup substitution is enabled. ### Who is affected - Opencast before 9.10 or 10.6 are affected - Log4j version: all 2.x versions before 2.15.0 are affected ### Patches The issue has been fixed in Opencast 9.10 and 10.6. ### Workarounds The vulnerability can be mitigated by setting system property `log4j2.formatMsgNoLookups` to `true`. ### References - [Opencast pull request mitigating the vulnerability](https://github.com/opencast/opencast/pull/3253) - [CVE-2021-44228 Detail](https://nvd.nist.gov/vuln/detail/CVE-2021-44228) - [Analysis and Remediation Guidance to the Log4j Zero-Day RCE (CVE-2021-44228) Vulnerability](https://www.veracode.com/blog/security-news/urgent-analysis-and-remediation-guidance-log4j-zero-day-rce-cve-2021-44228) - [VE-2021-44228 – Log4j 2 Vulnerability Analysis](https://www.randori.com/blog/cve-2021-44228/) ### For more information If you have any questions or comments about this advisory: * Open an issue in [our issue tracker](https://github.com/opencast/opencast/issues) * Email us at [security@opencast.org](mailto:security@opencast.org) ### Note about dependencies This issue affects many Java applications. Please also verify these are not vulnerable.

Affected packages and fixed versions

SourcePackageFixed in
maven::GitHub Security Advisory Mavenorg.opencastproject:opencast-common9.10, 10.6

References

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.