CVE-2026-73420
Auth.js: Email normalizer validates the address before Unicode normalization, allowing a homoglyph @ bypass
Severity by source
Trivy's own label is CRITICAL. Rated critical by GHSA.
Description
NextAuth.js provides authentication for Next.js. Prior to @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, the defaultNormalizer used by the email and magic-link sign-in flow validates an address before applying Unicode normalization. An address can contain a Unicode character such as U+FF20 FULLWIDTH COMMERCIAL AT that is not ASCII at-sign but canonicalizes to an ASCII at-sign under NFKC or NFKD normalization. The address passes the normalizer's single-at-sign check, but a downstream sendVerificationRequest mail library or delivery service that normalizes the address can then see two at-sign separators and deliver the passwordless sign-in link to an attacker-controlled recipient. Applications are affected when the email provider uses the built-in normalizer rather than a custom normalizeIdentifier and the downstream sender applies Unicode normalization. An attacker who knows a victim's email address can request the misrouted magic link and sign in as the victim without victim interaction. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| npm::GitHub Security Advisory npm | @auth/core, next-auth | 0.41.3 and 1 more |
| chainguard | jitsucom-jitsu, langfuse-3, langfuse-fips-3 | 2.11.0-r30 and 2 more |
| echo npm::Echo OSV | next-auth | 0.41.3 |
| minimos | langfuse-3 | 3.224.2-r0 |
| wolfi | jitsucom-jitsu, langfuse-3 | 2.11.0-r30 and 1 more |
Show all 9 entries from 5 sources
| Source | Package | Fixed in |
|---|---|---|
| npm::GitHub Security Advisory npm | @auth/core | 0.41.3 |
| npm::GitHub Security Advisory npm | next-auth | 4.24.15, 5.0.0-beta.32 |
| chainguard | jitsucom-jitsu | 2.11.0-r30 |
| chainguard | langfuse-3 | 3.225.7-r6 |
| chainguard | langfuse-fips-3 | 3.224.2-r0 |
| echo npm::Echo OSV | next-auth | 0.41.3 |
| minimos | langfuse-3 | 3.224.2-r0 |
| wolfi | jitsucom-jitsu | 2.11.0-r30 |
| wolfi | langfuse-3 | 3.225.7-r6 |
References
- https://advisory.echohq.com/cve/CVE-2026-73420
- https://github.com/nextauthjs/next-auth
- https://github.com/nextauthjs/next-auth/commit/19d2feb24359fa8c79418907fc68d9ec8152ca94
- https://github.com/nextauthjs/next-auth/commit/a63eee12a1a20cb35209e44195b097868517b9a0
- https://github.com/nextauthjs/next-auth/releases/tag/@auth/core@0.41.3
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth@4.24.15
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth@5.0.0-beta.32
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-7rqj-j65f-68wh