CVE-2026-5244
A vulnerability has been found in Cesanta Mongoose up to 7.20. This af ...
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD. Rated lower by Julia (medium).
Description
A vulnerability has been found in Cesanta Mongoose up to 7.20. This affects the function mg_tls_recv_cert of the file mongoose.c of the component TLS 1.3 Handler. Such manipulation of the argument pubkey leads to heap-based buffer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.21 mitigates this issue. The name of the patch is 0d882f1b43ff2308b7486a56a9d60cd6dba8a3f1. It is advisable to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| debian 11 | swupdate | no fix listed |
| debian 12 | swupdate | no fix listed |
| debian 13 | swupdate | no fix listed |
| debian 14 | swupdate | 2025.12+dfsg-10 |
| echo | swupdate | no fix listed |
| julia::Julia Ecosystem Security Advisories | Mongoose_jll | 7.21.0+0 |
| rapidfort debian 12 | swupdate | 0:2025.12+dfsg-10 |
| rapidfort debian 13 | swupdate | 0:2025.12+dfsg-10 |
References
- https://github.com/advisories/GHSA-7vfw-f3r2-9m2j
- https://github.com/cesanta/mongoose
- https://github.com/cesanta/mongoose/
- https://github.com/cesanta/mongoose/commit/0d882f1b43ff2308b7486a56a9d60cd6dba8a3f1
- https://github.com/cesanta/mongoose/releases/tag/7.21
- https://nvd.nist.gov/vuln/detail/CVE-2026-5244
- https://vuldb.com/submit/770063
- https://vuldb.com/vuln/354825