CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, Bitnami.
Description
Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | apisix | 3.17.0 |
| minimos | apache-apisix | 3.17.0-r0 |