CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, Bitnami.
Description
Improper Validation of Integrity Check Value vulnerability in Apache APISIX. The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass. This issue affects Apache APISIX: from 3.8.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | apisix | 3.17.0 |
| minimos | apache-apisix | 3.17.0-r0 |