Vulnerabilities / CVE-2026-44477

critical

CVE-2026-44477

github.com/cloudnative-pg/cloudnative-pg: CloudNativePG: Metrics exporter allows privilege escalation to PostgreSQL superuser and OS RCE

Published Modified CWE 250, 271, 426
In the Trivy database since at least 24 Oct 2026, 07:11 UTCWhen it arrived before that build is not recorded.

Severity by source

NVD9.9CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
GHSA9.4CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Red Hat8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Trivy's own label is CRITICAL. Rated critical by NVD, GHSA. Rated lower by Red Hat (high).

Description

CloudNativePG is a platform designed to manage PostgreSQL databases within Kubernetes environments. Prior to 1.29.1 and 1.28.3, the CloudNativePG metrics exporter opens its PostgreSQL connection as the postgres superuser via the pod-local Unix socket, then demotes the session with SET ROLE pg_monitor. SET ROLE changes only current_user; session_user remains postgres. Any SQL expression evaluated inside the scrape session can invoke RESET ROLE to recover real superuser privileges, then use COPY ... TO PROGRAM to spawn an OS-level subprocess as the postgres user inside the primary pod. The READ ONLY transaction flag does not block this; it gates writes to database state, not external processes. This vulnerability is fixed in 1.29.1 and 1.28.3.

Affected packages and fixed versions

SourcePackageFixed in
go::GitHub Security Advisory Gogithub.com/cloudnative-pg/cloudnative-pg1.28.3, 1.29.1
chainguardcloudnative-pg, cloudnative-pg-fips, plugin-barman-cloud and 1 more1.29.1-r0 and 2 more
minimoscloudnative-pg, cloudnative-pg-plugin-barman-cloud-0.11, cloudnative-pg-plugin-barman-cloud-0.12 and 2 more1.29.1-r0 and 2 more
wolficloudnative-pg1.29.1-r0
Show all 11 entries from 4 sources
SourcePackageFixed in
go::GitHub Security Advisory Gogithub.com/cloudnative-pg/cloudnative-pg1.28.3, 1.29.1
chainguardcloudnative-pg1.29.1-r0
chainguardcloudnative-pg-fips1.29.1-r0
chainguardplugin-barman-cloud0.12.0-r3
chainguardplugin-barman-cloud-fips0.12.0-r4
minimoscloudnative-pg1.29.1-r0
minimoscloudnative-pg-plugin-barman-cloud-0.110.11.0-r7
minimoscloudnative-pg-plugin-barman-cloud-0.120.12.0-r6
minimoscloudnative-pg-plugin-barman-cloud-fips-0.110.11.0-r7
minimoscloudnative-pg-plugin-barman-cloud-fips-0.120.12.0-r6
wolficloudnative-pg1.29.1-r0

References

All 10 references

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.