CVE-2025-66568
Ruby-saml allows a Libxml2 Canonicalization error to bypass Digest/Signature validation
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, GHSA, Ruby Advisory DB.
Description
The ruby-saml library implements the client side of an SAML authorization. Versions up to and including 1.12.4, are vulnerable to authentication bypass through the libxml2 canonicalization process used by Nokogiri for document transformation, which allows an attacker to execute a Signature Wrapping attack. When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. ruby-saml then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. This issue is fixed in version 1.18.0.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| rubygems::GitHub Security Advisory RubyGems | ruby-saml | 1.18.0 |
| rubygems::Ruby Advisory Database | ruby-saml | >= 1.18.0 |
| rapidfort ubuntu 20.04 | ruby-saml | no fix listed |
| rapidfort ubuntu 22.04 | ruby-saml | no fix listed |
| rapidfort ubuntu 24.04 | ruby-saml | no fix listed |
References
- https://github.com/SAML-Toolkits/ruby-saml
- https://github.com/SAML-Toolkits/ruby-saml/commit/acac9e9cc0b9a507882c614f25d41f8b47be349a
- https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-x4h9-gwv3-r4m4
- https://github.com/advisories/GHSA-x4h9-gwv3-r4m4
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2025-66568.yml
- https://nvd.nist.gov/vuln/detail/CVE-2025-66568