CVE-2025-58360
GeoServer is vulnerable to Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD. Rated lower by GHSA (high).
Description
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.geoserver.web:gs-web-app, org.geoserver:gs-wms | 2.26.2, 2.25.6 |
Show all 2 entries from 1 source
| Source | Package | Fixed in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.geoserver.web:gs-web-app | 2.26.2, 2.25.6 |
| maven::GitHub Security Advisory Maven | org.geoserver:gs-wms | 2.26.2, 2.25.6 |