CVE-2024-3203
A vulnerability, which was classified as critical, was found in c-blos ...
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD.
Description
A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| debian 13 | c-blosc2 | 2.13.1+ds-3 |
| debian 14 | c-blosc2 | 2.13.1+ds-3 |
| echo | c-blosc2 | 2.13.1+ds-3 |