CVE-2024-22399
Apache Seata Deserialization of Untrusted Data vulnerability
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, GHSA.
Description
Deserialization of Untrusted Data vulnerability in Apache Seata. When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protocol. This issue affects Apache Seata: 2.0.0, from 1.0.0 through 1.8.0. Users are recommended to upgrade to version 2.1.0/1.8.1, which fixes the issue.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.seata:seata-core | 2.1.0, 1.8.1 |