CVE-2023-31062
Apache InLong Improper Privilege Management vulnerability
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, GHSA.
Description
Improper Privilege Management Vulnerabilities in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.2.0 through 1.6.0. When the attacker has access to a valid (but unprivileged) account, the exploit can be executed using Burp Suite by sending a login request and following it with a subsequent HTTP request using the returned cookie. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 to solve it.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-dao, org.apache.inlong:manager-pojo, org.apache.inlong:manager-service and 1 more | 1.7.0 |
Show all 4 entries from 1 source
| Source | Package | Fixed in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-dao | 1.7.0 |
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-pojo | 1.7.0 |
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-service | 1.7.0 |
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-web | 1.7.0 |