CVE-2023-29216
Apache Linkis DatasourceManager module has deserialization vulnerability
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, GHSA.
Description
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.linkis:linkis-datasource | 1.3.2 |