CVE-2021-37404
hadoop-hdfs: Heap buffer overflow in Apache Hadoop libhdfs
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, GHSA. Rated lower by Red Hat (medium).
Description
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.hadoop:hadoop-common | 3.3.2, 3.2.3, 2.10.2 |
References
- https://access.redhat.com/security/cve/CVE-2021-37404
- https://github.com/apache/hadoop
- https://lists.apache.org/thread/2h56ztcj3ojc66qzf1nno88vjw9vd4wo
- https://nvd.nist.gov/vuln/detail/CVE-2021-37404
- https://security.netapp.com/advisory/ntap-20220715-0007
- https://security.netapp.com/advisory/ntap-20220715-0007/
- https://www.cve.org/CVERecord?id=CVE-2021-37404