Vulnerabilities / CVE-2021-29462

critical

CVE-2021-29462

The Portable SDK for UPnP Devices is an SDK for development of UPnP de ...

Published Modified CWE 20, 345
In the Trivy database since at least 24 Oct 2026, 07:11 UTCWhen it arrived before that build is not recorded.

Severity by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Trivy's own label is CRITICAL. Rated critical by NVD.

Description

The Portable SDK for UPnP Devices is an SDK for development of UPnP device and control point applications. The server part of pupnp (libupnp) appears to be vulnerable to DNS rebinding attacks because it does not check the value of the `Host` header. This can be mitigated by using DNS revolvers which block DNS-rebinding attacks. The vulnerability is fixed in version 1.14.6 and later.

Affected packages and fixed versions

SourcePackageFixed in
debian 10pupnp-1.8no fix listed
debian 11pupnp-1.8no fix listed
debian 12pupnp-1.8no fix listed
debian 9libupnpno fix listed
echopupnp-1.8no fix listed
rapidfort debian 12pupnp-1.8no fix listed
rapidfort debian 13pupnp-1.8no fix listed

References

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.