CVE-2020-15269
Ensure that doorkeeper_token is valid when authenticating requests in API v2 calls
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD. Rated lower by GHSA (high), Ruby Advisory DB (high).
Description
In Spree before versions 3.7.11, 4.0.4, or 4.1.11, expired user tokens could be used to access Storefront API v2 endpoints. The issue is patched in versions 3.7.11, 4.0.4 and 4.1.11. A workaround without upgrading is described in the linked advisory.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| rubygems::GitHub Security Advisory RubyGems | spree | 3.7.11, 4.0.4, 4.1.11 |
| rubygems::Ruby Advisory Database | spree | ~> 3.7.11, ~> 4.0.4, >= 4.1.11 |
References
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/spree/CVE-2020-15269.yml
- https://github.com/spree/spree
- https://github.com/spree/spree/commit/e43643abfe51f54bd9208dd02298b366e9b9a847
- https://github.com/spree/spree/security/advisories/GHSA-f8cm-364f-q9qh
- https://nvd.nist.gov/vuln/detail/CVE-2020-15269