CVE-2020-11973
camel: Netty enables Java deserialization by default which could leed to remote code execution
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD, GHSA. Rated lower by Red Hat (high).
Description
Apache Camel Netty enables Java deserialization by default. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0 are affected. 2.x users should upgrade to 2.25.1, 3.x users should upgrade to 3.2.0.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.camel:camel-netty | 3.2.0 |
References
- http://www.openwall.com/lists/oss-security/2020/05/14/9
- https://access.redhat.com/security/cve/CVE-2020-11973
- https://camel.apache.org/security/CVE-2020-11973.html
- https://github.com/apache/camel
- https://nvd.nist.gov/vuln/detail/CVE-2020-11973
- https://www.cve.org/CVERecord?id=CVE-2020-11973
- https://www.oracle.com//security-alerts/cpujul2021.html
- https://www.oracle.com/security-alerts/cpuApr2021.html