Vulnerabilities / CVE-2019-1010228

critical

CVE-2019-1010228

OFFIS.de DCMTK 3.6.3 and below is affected by: Buffer Overflow. The im ...

Published Modified CWE 787
In the Trivy database since at least 24 Oct 2026, 07:11 UTCWhen it arrived before that build is not recorded.

Severity by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Trivy's own label is CRITICAL. Rated critical by NVD. Rated lower by Ubuntu (medium).

Description

OFFIS.de DCMTK 3.6.3 and below is affected by: Buffer Overflow. The impact is: Possible code execution and confirmed Denial of Service. The component is: DcmRLEDecoder::decompress() (file dcrledec.h, line 122). The attack vector is: Many scenarios of DICOM file processing (e.g. DICOM to image conversion). The fixed version is: 3.6.4, after commit 40917614e.

Affected packages and fixed versions

SourcePackageFixed in
debian 11dcmtk3.6.4-1
debian 12dcmtk3.6.4-1
debian 13dcmtk3.6.4-1
debian 14dcmtk3.6.4-1
debian 8dcmtkno fix listed
debian 9dcmtkno fix listed
echodcmtk3.6.4-1
ubuntu 16.04-ESMdcmtk3.6.1~20150924-5ubuntu0.1~esm1
ubuntu 18.04-ESMdcmtk3.6.2-3ubuntu0.1~esm1

References

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.