CVE-2019-1010174
CImg The CImg Library v.2.3.3 and earlier is affected by: command inje ...
Severity by source
Trivy's own label is CRITICAL. Rated critical by NVD. Rated lower by Ubuntu (medium).
Description
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
Affected packages and fixed versions
| Source | Package | Fixed in |
|---|---|---|
| debian 11 | cimg | 2.3.6+dfsg-1 |
| debian 12 | cimg | 2.3.6+dfsg-1 |
| debian 13 | cimg | 2.3.6+dfsg-1 |
| debian 14 | cimg | 2.3.6+dfsg-1 |
| debian 8 | cimg | 1.5.9+dfsg-1+deb8u1 |
| debian 9 | cimg | 1.7.9+dfsg-1+deb9u1 |
| echo | cimg | 2.3.6+dfsg-1 |
| ubuntu 18.04-ESM | cimg | no fix listed |
References
- https://framagit.org/dtschump/CImg/commit/5ce7a426b77f814973e56182a0e76a2b04904146
- https://framagit.org/dtschump/CImg/commit/5ce7a426b77f814973e56182a0e76a2b04904146%20%28v.2.3.4%29
- https://lists.debian.org/debian-lts-announce/2019/09/msg00030.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00033.html
- https://www.cve.org/CVERecord?id=CVE-2019-1010174