Schwachstellen / CVE-2026-48805

kritisch

CVE-2026-48805

Twig is a template language for PHP. Prior to 3.27.0, deprecated inter ...

Veröffentlicht Geändert CWE 693
In der Trivy Database seit spätestens 24. Okt. 2026, 07:11 UTCWann der Eintrag vor diesem Build hinzukam, ist nicht erfasst.

Einstufung nach Quelle

NVD9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Trivys eigenes Label ist CRITICAL. Kritisch laut NVD. Niedriger laut GHSA (niedrig).

Beschreibung

Twig is a template language for PHP. Prior to 3.27.0, deprecated internal wrappers in src/Resources/core.php do not forward the current sandbox state to CoreExtension::checkArrow(), arraySome(), and arrayEvery(), allowing legacy calls such as twig_array_some(), twig_array_every(), and twig_check_arrow_in_sandbox() to bypass sandbox callable restrictions. This issue is fixed in version 3.27.0.

Betroffene Pakete und behobene Versionen

QuellePaketBehoben in
composer::GitHub Security Advisory Composertwig/twig3.27.0
composer::PHP Security Advisories Databasetwig/twigkein Fix angegeben
debian 11php-twigkein Fix angegeben
debian 12php-twigkein Fix angegeben
debian 13php-twig3.27.0-0+deb13u1
debian 14php-twig3.27.0-1
echophp-twig3.27.0-0+deb13u1
rapidfort debian 12php-twig0:3.27.0-0+deb13u1, 0:3.27.0-1
rapidfort debian 13php-twig0:3.27.0-0+deb13u1, 0:3.27.0-1

Referenzen

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.