Schwachstellen / CVE-2026-34060

kritisch

CVE-2026-34060

Ruby LSP is an implementation of the language server protocol for Ruby ...

Veröffentlicht Geändert CWE 94
In der Trivy Database seit spätestens 24. Okt. 2026, 07:11 UTCWann der Eintrag vor diesem Build hinzukam, ist nicht erfasst.

Einstufung nach Quelle

GHSA7.1CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Trivys eigenes Label ist CRITICAL. Kritisch laut Ruby Advisory DB. Niedriger laut GHSA (hoch).

Beschreibung

Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.

Betroffene Pakete und behobene Versionen

QuellePaketBehoben in
rubygems::Ruby Advisory Databaseruby-lsp>= 0.26.9
debian 14ruby-ruby-lsp0.26.9-0.1
rubygems::GitHub Security Advisory RubyGemsruby-lsp0.26.9

Referenzen

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.