CVE-2025-67647
SvelteKit is vulnerable to denial of service and possible SSRF when using prerendering
Einstufung nach Quelle
Trivys eigenes Label ist CRITICAL. Kritisch laut NVD. Niedriger laut GHSA (hoch).
Beschreibung
SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.
Betroffene Pakete und behobene Versionen
| Quelle | Paket | Behoben in |
|---|---|---|
| npm::GitHub Security Advisory npm | @sveltejs/adapter-node, @sveltejs/kit | 5.5.1 und 1 weitere |
Alle 2 Einträge aus 1 Quelle zeigen
| Quelle | Paket | Behoben in |
|---|---|---|
| npm::GitHub Security Advisory npm | @sveltejs/adapter-node | 5.5.1 |
| npm::GitHub Security Advisory npm | @sveltejs/kit | 2.49.5 |
Referenzen
- https://github.com/sveltejs/kit
- https://github.com/sveltejs/kit/commit/d9ae9b00b14f5574d109f3fd548f960594346226
- https://github.com/sveltejs/kit/releases/tag/@sveltejs%2Fadapter-node@5.5.1
- https://github.com/sveltejs/kit/releases/tag/@sveltejs%2Fkit@2.49.5
- https://github.com/sveltejs/kit/security/advisories/GHSA-j62c-4x62-9r35
- https://nvd.nist.gov/vuln/detail/CVE-2025-67647