CVE-2025-59059
Apache Ranger has a Code Injection vulnerability
Einstufung nach Quelle
Trivys eigenes Label ist CRITICAL. Kritisch laut GHSA.
Beschreibung
Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.
Betroffene Pakete und behobene Versionen
| Quelle | Paket | Behoben in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.ranger:ranger-plugins-common | 2.8.0 |
| chainguard | druid, trino | 36.0.0-r3 und 1 weitere |
| echo maven::Echo OSV | org.apache.ranger:ranger-plugins-common | 2.8.0 |
| rapidfort alpine 3.20 | ranger | kein Fix angegeben |
| rapidfort alpine 3.21 | ranger | kein Fix angegeben |
| rapidfort alpine 3.22 | ranger | kein Fix angegeben |
| rapidfort alpine 3.23 | ranger | kein Fix angegeben |
| rapidfort alpine 3.24 | ranger | kein Fix angegeben |
| rapidfort fedora 43 | ranger | 1.9.4-9.fc43 |
| rapidfort Oracle Linux 10 | ranger | kein Fix angegeben |
| rapidfort Oracle Linux 9 | ranger | kein Fix angegeben |
| wolfi | druid, trino | 36.0.0-r3 und 1 weitere |
Alle 14 Einträge aus 12 Quellen zeigen
| Quelle | Paket | Behoben in |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.ranger:ranger-plugins-common | 2.8.0 |
| chainguard | druid | 36.0.0-r3 |
| chainguard | trino | 480-r0 |
| echo maven::Echo OSV | org.apache.ranger:ranger-plugins-common | 2.8.0 |
| rapidfort alpine 3.20 | ranger | kein Fix angegeben |
| rapidfort alpine 3.21 | ranger | kein Fix angegeben |
| rapidfort alpine 3.22 | ranger | kein Fix angegeben |
| rapidfort alpine 3.23 | ranger | kein Fix angegeben |
| rapidfort alpine 3.24 | ranger | kein Fix angegeben |
| rapidfort fedora 43 | ranger | 1.9.4-9.fc43 |
| rapidfort Oracle Linux 10 | ranger | kein Fix angegeben |
| rapidfort Oracle Linux 9 | ranger | kein Fix angegeben |
| wolfi | druid | 36.0.0-r3 |
| wolfi | trino | 480-r0 |