CVE-2021-32714
hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper ...
Einstufung nach Quelle
Trivys eigenes Label ist CRITICAL. Kritisch laut NVD, Azure Linux. Niedriger laut GHSA (mittel), Ubuntu (mittel).
Beschreibung
hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.
Betroffene Pakete und behobene Versionen
| Quelle | Paket | Behoben in |
|---|---|---|
| Azure Linux 3.0 | rpm-ostree | 0:2024.4-1.azl3 |
| cargo::GitHub Security Advisory Rust | hyper | 0.14.10 |
| chainguard | chaos-tproxy | 0.5.4-r2 |
| debian 12 | rust-hyper | 0.14.19-1 |
| debian 13 | rust-hyper | 0.14.19-1 |
| debian 14 | rust-hyper | 0.14.19-1 |
| echo | rust-hyper | 0.14.19-1 |
| ubuntu 20.04-ESM | rust-hyper | kein Fix angegeben |