Zafiyetler / CVE-2022-23457

kritik

CVE-2022-23457

ESAPI (The OWASP Enterprise Security API) is a free, open source, web ...

Yayın Değişiklik CWE 22
En geç 24 Eki 2026, 07:11 UTC tarihinden beri Trivy database'indeO derlemeden önce ne zaman girdiği kayıtlı değil.

Kaynağa göre önem derecesi

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GHSA7.5CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Trivy'nin kendi etiketi CRITICAL. Kritik diyenler: NVD. Daha düşük diyenler: GHSA (yüksek), Ubuntu (düşük).

Açıklama

ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of `Validator.getValidDirectoryPath(String, String, File, boolean)` may incorrectly treat the tested input string as a child of the specified parent directory. This potentially could allow control-flow bypass checks to be defeated if an attack can specify the entire string representing the 'input' path. This vulnerability is patched in release 2.3.0.0 of ESAPI. As a workaround, it is possible to write one's own implementation of the Validator interface. However, maintainers do not recommend this.

Etkilenen paketler ve düzeltilmiş sürümler

KaynakPaketDüzeltildiği sürüm
debian 10libowasp-esapi-javadüzeltme belirtilmemiş
debian 11libowasp-esapi-java2.4.0.0-0+deb11u1
debian 12libowasp-esapi-java2.4.0.0-1
debian 13libowasp-esapi-java2.4.0.0-1
debian 9libowasp-esapi-javadüzeltme belirtilmemiş
echolibowasp-esapi-java2.4.0.0-1
maven::GitHub Security Advisory Mavenorg.owasp.esapi:esapi2.3.0.0
rapidfort ubuntu 20.04libowasp-esapi-java0:2.4.0.0-1
rapidfort ubuntu 22.04libowasp-esapi-java0:2.4.0.0-1
rapidfort ubuntu 24.04libowasp-esapi-java0:2.4.0.0-1
ubuntu 16.04-ESMlibowasp-esapi-java2.1.0-2ubuntu0.1~esm1
ubuntu 18.04-ESMlibowasp-esapi-java2.1.0-3ubuntu0.18.04.1~esm1
14 kaynaktaki 14 kaydın hepsini göster
KaynakPaketDüzeltildiği sürüm
debian 10libowasp-esapi-javadüzeltme belirtilmemiş
debian 11libowasp-esapi-java2.4.0.0-0+deb11u1
debian 12libowasp-esapi-java2.4.0.0-1
debian 13libowasp-esapi-java2.4.0.0-1
debian 9libowasp-esapi-javadüzeltme belirtilmemiş
echolibowasp-esapi-java2.4.0.0-1
maven::GitHub Security Advisory Mavenorg.owasp.esapi:esapi2.3.0.0
rapidfort ubuntu 20.04libowasp-esapi-java0:2.4.0.0-1
rapidfort ubuntu 22.04libowasp-esapi-java0:2.4.0.0-1
rapidfort ubuntu 24.04libowasp-esapi-java0:2.4.0.0-1
ubuntu 16.04-ESMlibowasp-esapi-java2.1.0-2ubuntu0.1~esm1
ubuntu 18.04-ESMlibowasp-esapi-java2.1.0-3ubuntu0.18.04.1~esm1
ubuntu 20.04-ESMlibowasp-esapi-java2.1.0-3ubuntu0.20.04.1~esm1
ubuntu 22.04libowasp-esapi-javadüzeltme belirtilmemiş

Referanslar

14 referansın hepsi

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.