CVE-2022-23457
ESAPI (The OWASP Enterprise Security API) is a free, open source, web ...
Sévérité par source
Le label propre à Trivy est CRITICAL. Critique selon NVD. Plus basse selon GHSA (élevée), Ubuntu (faible).
Description
ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of `Validator.getValidDirectoryPath(String, String, File, boolean)` may incorrectly treat the tested input string as a child of the specified parent directory. This potentially could allow control-flow bypass checks to be defeated if an attack can specify the entire string representing the 'input' path. This vulnerability is patched in release 2.3.0.0 of ESAPI. As a workaround, it is possible to write one's own implementation of the Validator interface. However, maintainers do not recommend this.
Paquets affectés et versions corrigées
| Source | Paquet | Corrigé en |
|---|---|---|
| debian 10 | libowasp-esapi-java | pas de correctif indiqué |
| debian 11 | libowasp-esapi-java | 2.4.0.0-0+deb11u1 |
| debian 12 | libowasp-esapi-java | 2.4.0.0-1 |
| debian 13 | libowasp-esapi-java | 2.4.0.0-1 |
| debian 9 | libowasp-esapi-java | pas de correctif indiqué |
| echo | libowasp-esapi-java | 2.4.0.0-1 |
| maven::GitHub Security Advisory Maven | org.owasp.esapi:esapi | 2.3.0.0 |
| rapidfort ubuntu 20.04 | libowasp-esapi-java | 0:2.4.0.0-1 |
| rapidfort ubuntu 22.04 | libowasp-esapi-java | 0:2.4.0.0-1 |
| rapidfort ubuntu 24.04 | libowasp-esapi-java | 0:2.4.0.0-1 |
| ubuntu 16.04-ESM | libowasp-esapi-java | 2.1.0-2ubuntu0.1~esm1 |
| ubuntu 18.04-ESM | libowasp-esapi-java | 2.1.0-3ubuntu0.18.04.1~esm1 |
Afficher les 14 entrées de 14 sources
| Source | Paquet | Corrigé en |
|---|---|---|
| debian 10 | libowasp-esapi-java | pas de correctif indiqué |
| debian 11 | libowasp-esapi-java | 2.4.0.0-0+deb11u1 |
| debian 12 | libowasp-esapi-java | 2.4.0.0-1 |
| debian 13 | libowasp-esapi-java | 2.4.0.0-1 |
| debian 9 | libowasp-esapi-java | pas de correctif indiqué |
| echo | libowasp-esapi-java | 2.4.0.0-1 |
| maven::GitHub Security Advisory Maven | org.owasp.esapi:esapi | 2.3.0.0 |
| rapidfort ubuntu 20.04 | libowasp-esapi-java | 0:2.4.0.0-1 |
| rapidfort ubuntu 22.04 | libowasp-esapi-java | 0:2.4.0.0-1 |
| rapidfort ubuntu 24.04 | libowasp-esapi-java | 0:2.4.0.0-1 |
| ubuntu 16.04-ESM | libowasp-esapi-java | 2.1.0-2ubuntu0.1~esm1 |
| ubuntu 18.04-ESM | libowasp-esapi-java | 2.1.0-3ubuntu0.18.04.1~esm1 |
| ubuntu 20.04-ESM | libowasp-esapi-java | 2.1.0-3ubuntu0.20.04.1~esm1 |
| ubuntu 22.04 | libowasp-esapi-java | pas de correctif indiqué |
Références
- https://github.com/ESAPI/esapi-java-legacy
- https://github.com/ESAPI/esapi-java-legacy/blob/develop/documentation/GHSL-2022-008_The_OWASP_Enterprise_Security_API.md
- https://github.com/ESAPI/esapi-java-legacy/blob/develop/documentation/esapi4java-core-2.3.0.0-release-notes.txt
- https://github.com/ESAPI/esapi-java-legacy/commit/a0d67b75593878b1b6e39e2acc1773b3effedb2a
- https://github.com/ESAPI/esapi-java-legacy/security/advisories/GHSA-8m5h-hrqm-pxm2
- https://lists.debian.org/debian-lts-announce/2025/07/msg00010.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-23457
- https://security.netapp.com/advisory/ntap-20230127-0014
Les 14 références
- https://security.netapp.com/advisory/ntap-20230127-0014/
- https://securitylab.github.com/advisories/GHSL-2022-008_The_OWASP_Enterprise_Security_API
- https://securitylab.github.com/advisories/GHSL-2022-008_The_OWASP_Enterprise_Security_API/
- https://ubuntu.com/security/notices/USN-8181-1
- https://www.cve.org/CVERecord?id=CVE-2022-23457
- https://www.oracle.com/security-alerts/cpujul2022.html