Vulnérabilités / CVE-2025-66567

critique

CVE-2025-66567

Ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)

Publiée Modifiée CWE 347
Dans la Trivy database depuis au moins le 24 oct. 2026, 07:11 UTCLa date d'entrée avant ce build n'est pas enregistrée.

Sévérité par source

NVD9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
GHSA9.3CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Le label propre à Trivy est CRITICAL. Critique selon NVD, GHSA, Ruby Advisory DB.

Description

The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.

Paquets affectés et versions corrigées

SourcePaquetCorrigé en
rubygems::GitHub Security Advisory RubyGemsruby-saml1.18.0
rubygems::Ruby Advisory Databaseruby-saml>= 1.18.0
rapidfort ubuntu 20.04ruby-samlpas de correctif indiqué
rapidfort ubuntu 22.04ruby-samlpas de correctif indiqué
rapidfort ubuntu 24.04ruby-samlpas de correctif indiqué

Références

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.