CVE-2025-66567
Ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según NVD, GHSA, Ruby Advisory DB.
Descripción
The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| rubygems::GitHub Security Advisory RubyGems | ruby-saml | 1.18.0 |
| rubygems::Ruby Advisory Database | ruby-saml | >= 1.18.0 |
| rapidfort ubuntu 20.04 | ruby-saml | sin corrección indicada |
| rapidfort ubuntu 22.04 | ruby-saml | sin corrección indicada |
| rapidfort ubuntu 24.04 | ruby-saml | sin corrección indicada |
Referencias
- https://github.com/SAML-Toolkits/ruby-saml
- https://github.com/SAML-Toolkits/ruby-saml/commit/e9c1cdbd0f9afa467b585de279db0cbd0fb8ae97
- https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-9v8j-x534-2fx3
- https://github.com/advisories/GHSA-754f-8gm6-c4r2
- https://github.com/advisories/GHSA-9v8j-x534-2fx3
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2025-66567.yml
- https://nvd.nist.gov/vuln/detail/CVE-2025-66567