Zafiyetler / CVE-2025-58068

kritik

CVE-2025-58068

python-eventlet: Eventlet HTTP request smuggling

Yayın Değişiklik CWE 444
En geç 24 Eki 2026, 07:11 UTC tarihinden beri Trivy database'indeO derlemeden önce ne zaman girdiği kayıtlı değil.

Kaynağa göre önem derecesi

NVD9.1CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
GHSA6.3CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Red Hat6.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Trivy'nin kendi etiketi CRITICAL. Kritik diyenler: NVD. Daha düşük diyenler: GHSA (orta), Red Hat (orta), Ubuntu (orta).

Açıklama

Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.

Etkilenen paketler ve düzeltilmiş sürümler

KaynakPaketDüzeltildiği sürüm
debian 11python-eventlet0.26.1-7+deb11u2
debian 12python-eventletdüzeltme belirtilmemiş
debian 13python-eventlet0.39.1-2+deb13u1
debian 14python-eventlet0.40.1-3
echopython-eventlet0.39.1-2+deb13u1
echo pip::Echo OSVeventlet0.40.3
pip::GitHub Security Advisory pipeventlet0.40.3
rapidfort debian 12python-eventlet0:0.39.1-2+deb13u1, 0:0.40.1-3
rapidfort debian 13python-eventlet0:0.39.1-2+deb13u1, 0:0.40.1-3
rapidfort ubuntu 20.04python-eventlet, rf-python-eventlet0:0.35.2-0ubuntu1.1
rapidfort ubuntu 22.04python-eventlet, rf-python-eventlet0:0.35.2-0ubuntu1.1
rapidfort ubuntu 24.04python-eventlet, rf-python-eventlet0:0.35.2-0ubuntu1.1
20 kaynaktaki 26 kaydın hepsini göster
KaynakPaketDüzeltildiği sürüm
debian 11python-eventlet0.26.1-7+deb11u2
debian 12python-eventletdüzeltme belirtilmemiş
debian 13python-eventlet0.39.1-2+deb13u1
debian 14python-eventlet0.40.1-3
echopython-eventlet0.39.1-2+deb13u1
echo pip::Echo OSVeventlet0.40.3
pip::GitHub Security Advisory pipeventlet0.40.3
rapidfort debian 12python-eventlet0:0.39.1-2+deb13u1, 0:0.40.1-3
rapidfort debian 13python-eventlet0:0.39.1-2+deb13u1, 0:0.40.1-3
rapidfort ubuntu 20.04python-eventlet0:0.35.2-0ubuntu1.1
rapidfort ubuntu 20.04rf-python-eventlet0:0.35.2-0ubuntu1.1
rapidfort ubuntu 22.04python-eventlet0:0.35.2-0ubuntu1.1
rapidfort ubuntu 22.04rf-python-eventlet0:0.35.2-0ubuntu1.1
rapidfort ubuntu 24.04python-eventlet0:0.35.2-0ubuntu1.1
rapidfort ubuntu 24.04rf-python-eventlet0:0.35.2-0ubuntu1.1
Red Hatopenshift4/ose-ironic-agent-rhel9düzeltme belirtilmemiş
Red Hatopenshift4/ose-ironic-rhel9düzeltme belirtilmemiş
Red Hatpython-eventletdüzeltme belirtilmemiş
Red Hatpython3-eventletdüzeltme belirtilmemiş
ubuntu 20.04-ESMpython-eventlet0.25.1-2ubuntu1.1+esm2
ubuntu 22.04python-eventlet0.30.2-5ubuntu2.2
ubuntu 24.04python-eventlet0.35.2-0ubuntu1.1
ubuntu 25.04python-eventlet0.39.0-0ubuntu1.1
ubuntu 25.10python-eventlet0.39.0-0ubuntu2
ubuntu 26.04python-eventlet0.39.0-0ubuntu2
ubuntu 26.10python-eventlet0.39.0-0ubuntu2

Referanslar

13 referansın hepsi

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.