CVE-2022-41892
Arches vulnerable to execution of arbitrary SQL
Kaynağa göre önem derecesi
Trivy'nin kendi etiketi CRITICAL. Kritik diyenler: NVD. Daha düşük diyenler: GHSA (yüksek).
Açıklama
Arches is a web platform for creating, managing, & visualizing geospatial data. Versions prior to 6.1.2, 6.2.1, and 7.1.2 are vulnerable to SQL Injection. With a carefully crafted web request, it's possible to execute certain unwanted sql statements against the database. This issue is fixed in version 7.12, 6.2.1, and 6.1.2. Users are recommended to upgrade as soon as possible. There are no workarounds.
Etkilenen paketler ve düzeltilmiş sürümler
| Kaynak | Paket | Düzeltildiği sürüm |
|---|---|---|
| pip::GitHub Security Advisory pip | arches | 6.1.2, 6.2.1, 7.2.0 |
Referanslar
- https://github.com/archesproject/arches
- https://github.com/archesproject/arches/commit/7ed53e23a616edf3301d95814d9d64de5e3072a9
- https://github.com/archesproject/arches/security/advisories/GHSA-gmpq-xrxj-xh8m
- https://github.com/pypa/advisory-database/tree/main/vulns/arches/PYSEC-2022-42985.yaml
- https://nvd.nist.gov/vuln/detail/CVE-2022-41892
- https://pypi.org/project/arches/6.1.2
- https://pypi.org/project/arches/7.2.0
- https://securitylab.github.com/advisories/GHSL-2022-070_GHSL-2022-072_Arches