CVE-2020-11972
camel: RabbitMQ enables Java deserialization by default which could leed to remote code execution
Kaynağa göre önem derecesi
Trivy'nin kendi etiketi CRITICAL. Kritik diyenler: NVD. Daha düşük diyenler: GHSA (yüksek), Red Hat (yüksek).
Açıklama
Apache Camel RabbitMQ enables Java deserialization by default. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0 are affected. 2.x users should upgrade to 2.25.1, 3.x users should upgrade to 3.2.0.
Etkilenen paketler ve düzeltilmiş sürümler
| Kaynak | Paket | Düzeltildiği sürüm |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.camel:camel-rabbitmq | 2.25.1, 3.2.0 |
Referanslar
- http://www.openwall.com/lists/oss-security/2020/05/14/10
- http://www.openwall.com/lists/oss-security/2020/05/14/8
- https://access.redhat.com/security/cve/CVE-2020-11972
- https://camel.apache.org/security/CVE-2020-11972.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-11972
- https://www.cve.org/CVERecord?id=CVE-2020-11972
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://www.oracle.com/security-alerts/cpuoct2020.html