CVE-2020-11020
Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1. ...
Kaynağa göre önem derecesi
Trivy'nin kendi etiketi CRITICAL. Kritik diyenler: NVD. Daha düşük diyenler: GHSA (yüksek), Ruby Advisory DB (yüksek).
Açıklama
Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.
Etkilenen paketler ve düzeltilmiş sürümler
| Kaynak | Paket | Düzeltildiği sürüm |
|---|---|---|
| debian 10 | ruby-faye | düzeltme belirtilmemiş |
| debian 11 | ruby-faye | 1.4.0-1 |
| debian 12 | ruby-faye | 1.4.0-1 |
| echo | ruby-faye | 1.4.0-1 |
| rubygems::GitHub Security Advisory RubyGems | faye | 1.0.4, 1.1.3, 1.2.5 |
| rubygems::Ruby Advisory Database | faye | ~> 1.0.4, ~> 1.1.3, >= 1.2.5 |
Referanslar
- https://github.com/faye/faye
- https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e
- https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/faye/CVE-2020-11020.yml
- https://nvd.nist.gov/vuln/detail/CVE-2020-11020