CVE-2018-1000132
mercurial: HTTP server permissions bypass
Kaynağa göre önem derecesi
Trivy'nin kendi etiketi CRITICAL. Kritik diyenler: NVD, GHSA, Photon OS. Daha düşük diyenler: Red Hat (orta), Oracle (orta), Ubuntu (orta).
Açıklama
Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.
Etkilenen paketler ve düzeltilmiş sürümler
| Kaynak | Paket | Düzeltildiği sürüm |
|---|---|---|
| Photon OS 1.0 | mercurial | 4.5.3-1.ph1 |
| Photon OS 2.0 | mercurial | 4.5.3-1.ph2 |
| pip::GitHub Security Advisory pip | mercurial | 4.5.1 |
| alpine 3.5 | mercurial | 4.5.2-r0 |
| alpine 3.6 | mercurial | 4.5.2-r0 |
| alpine 3.7 | mercurial | 4.5.2-r0 |
| debian 11 | mercurial | 4.5.2-1 |
| debian 12 | mercurial | 4.5.2-1 |
| debian 13 | mercurial | 4.5.2-1 |
| debian 14 | mercurial | 4.5.2-1 |
| debian 7 | mercurial | 2.2.2-4+deb7u7 |
| debian 8 | mercurial | 3.1.2-2+deb8u5 |
20 kaynaktaki 26 kaydın hepsini göster
| Kaynak | Paket | Düzeltildiği sürüm |
|---|---|---|
| Photon OS 1.0 | mercurial | 4.5.3-1.ph1 |
| Photon OS 2.0 | mercurial | 4.5.3-1.ph2 |
| pip::GitHub Security Advisory pip | mercurial | 4.5.1 |
| alpine 3.5 | mercurial | 4.5.2-r0 |
| alpine 3.6 | mercurial | 4.5.2-r0 |
| alpine 3.7 | mercurial | 4.5.2-r0 |
| debian 11 | mercurial | 4.5.2-1 |
| debian 12 | mercurial | 4.5.2-1 |
| debian 13 | mercurial | 4.5.2-1 |
| debian 14 | mercurial | 4.5.2-1 |
| debian 7 | mercurial | 2.2.2-4+deb7u7 |
| debian 8 | mercurial | 3.1.2-2+deb8u5 |
| debian 9 | mercurial | 4.0-1+deb9u2 |
| echo | mercurial | 4.5.2-1 |
| Oracle Linux 7 | emacs-mercurial | 2.6.2-10.el7 |
| Oracle Linux 7 | emacs-mercurial-el | 2.6.2-10.el7 |
| Oracle Linux 7 | mercurial | 2.6.2-10.el7 |
| Oracle Linux 7 | mercurial-hgk | 2.6.2-10.el7 |
| Red Hat | emacs-mercurial | düzeltme belirtilmemiş |
| Red Hat | emacs-mercurial-el | düzeltme belirtilmemiş |
| Red Hat | mercurial | düzeltme belirtilmemiş |
| Red Hat | mercurial-hgk | düzeltme belirtilmemiş |
| ubuntu 14.04 | mercurial | 2.8.2-1ubuntu1.4 |
| ubuntu 14.04-ESM | mercurial | 2.8.2-1ubuntu1.4 |
| ubuntu 16.04 | mercurial | 3.7.3-1ubuntu1.1 |
| ubuntu 16.04-ESM | mercurial | 3.7.3-1ubuntu1.1 |
Referanslar
- https://access.redhat.com/errata/RHSA-2019:2276
- https://access.redhat.com/security/cve/CVE-2018-1000132
- https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2018-87.yaml
- https://linux.oracle.com/cve/CVE-2018-1000132.html
- https://linux.oracle.com/errata/ELSA-2019-2276.html
- https://lists.debian.org/debian-lts-announce/2018/03/msg00034.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html