CVE-2026-46421
Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)
Sévérité par source
Aucune source ne donne de score CVSS.
Le label propre à Trivy est CRITICAL. Critique selon GHSA.
Description
The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/sqlite@2.2.2`, `@cap-js/postgres@2.2.2`, and `@cap-js/db-service@2.10.1` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.
Paquets affectés et versions corrigées
| Source | Paquet | Corrigé en |
|---|---|---|
| npm::GitHub Security Advisory npm | @cap-js/db-service, @cap-js/postgres, @cap-js/sqlite | 2.11.0 et 1 autres |
Afficher les 3 entrées d'une source
| Source | Paquet | Corrigé en |
|---|---|---|
| npm::GitHub Security Advisory npm | @cap-js/db-service | 2.11.0 |
| npm::GitHub Security Advisory npm | @cap-js/postgres | 2.3.0 |
| npm::GitHub Security Advisory npm | @cap-js/sqlite | 2.3.0 |