CVE-2026-44087
Apache APISIX: Openid-connect plugin Identity Header Spoofing
Sévérité par source
Le label propre à Trivy est CRITICAL. Critique selon NVD, Bitnami.
Description
Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Paquets affectés et versions corrigées
| Source | Paquet | Corrigé en |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | apisix | 3.17.0 |
| minimos | apache-apisix | 3.17.0-r0 |