CVE-2026-24713
Apache IoTDB has an Improper Input Validation vulnerability
Sévérité par source
Le label propre à Trivy est CRITICAL. Critique selon NVD, GHSA.
Description
Improper Input Validation vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
Paquets affectés et versions corrigées
| Source | Paquet | Corrigé en |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.iotdb:iotdb-core | 1.3.7, 2.0.7 |
Références
- http://www.openwall.com/lists/oss-security/2026/03/09/4
- https://github.com/apache/iotdb
- https://github.com/apache/iotdb/commit/8fbfddc5f83771f1b339c457de597fe877f686d2
- https://github.com/apache/iotdb/compare/v1.3.6...v1.3.7
- https://github.com/apache/iotdb/compare/v2.0.6...v2.0.7
- https://github.com/apache/iotdb/releases/tag/v1.3.7
- https://github.com/apache/iotdb/releases/tag/v2.0.7
- https://lists.apache.org/thread/vopgv6y2ccw403b0zv7rvojjrh7x1j5p