CVE-2025-61622
Apache Pyfory python is vulnerable to deserialization of untrusted data
Sévérité par source
Le label propre à Trivy est CRITICAL. Critique selon GHSA.
Description
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution. Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
Paquets affectés et versions corrigées
| Source | Paquet | Corrigé en |
|---|---|---|
| pip::GitHub Security Advisory pip | pyfory, pyfury | 0.12.3 |
Afficher les 2 entrées d'une source
| Source | Paquet | Corrigé en |
|---|---|---|
| pip::GitHub Security Advisory pip | pyfory | 0.12.3 |
| pip::GitHub Security Advisory pip | pyfury | pas de correctif indiqué |
Références
- http://www.openwall.com/lists/oss-security/2025/09/29/3
- https://github.com/apache/fory
- https://github.com/apache/fory/commit/379b948ecae5c3b849e5bdb3997978c9a163e40b
- https://github.com/apache/fory/pull/2629
- https://github.com/apache/fory/releases/tag/v0.12.3
- https://lists.apache.org/thread/vfn9hp9qt06db5yo1gmj3l114o3o2csd
- https://nvd.nist.gov/vuln/detail/CVE-2025-61622