Vulnérabilités / CVE-2025-59545

critique

CVE-2025-59545

DNN Vulnerable to Stored Cross-Site Scripting (XSS) in the Prompt module

Publiée Modifiée CWE 79
Dans la Trivy database depuis au moins le 24 oct. 2026, 07:11 UTCLa date d'entrée avant ce build n'est pas enregistrée.

Sévérité par source

GHSA9.1CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Le label propre à Trivy est CRITICAL. Critique selon GHSA.

Description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 10.1.0, the Prompt module allows execution of commands that can return raw HTML. Malicious input, even if sanitized for display elsewhere, can be executed when processed through certain commands, leading to potential script execution (XSS). This issue has been patched in version 10.1.0.

Paquets affectés et versions corrigées

SourcePaquetCorrigé en
nuget::GitHub Security Advisory NuGetDotNetNuke.Core, dotnetnuke.core10.1.0
Afficher les 2 entrées d'une source
SourcePaquetCorrigé en
nuget::GitHub Security Advisory NuGetDotNetNuke.Core10.1.0
nuget::GitHub Security Advisory NuGetdotnetnuke.core10.1.0

Références

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.